bing tracking image
Q & A Icon

Troubleshooting Turn Signal Issue with Wiring Harness 118400 on a 2007 Honda Ridgeline

Question:

On the right trailer side the turn signal did not work unless the turn bulb is removed from the vehicle. Strange! It is as though the output does not have enough output to power both bulbs. Does the device contain electronic circuitry or is it just wire connections? I replaced the whole light on the trailer which did not help. Should I buy another and give it a try?

0

Expert Reply:

I would check a few things first, before replacing the unit. First, you should check the ground wire at the screw you should have installed and make sure that it is firmly connected to a clean piece of metal, i.e. a location without paint, rust, or buildup.

I also recommend checking the ground wires on your trailer, including the ground on the trailer connector, and any trailer lights. If your trailer lights are grounded through the mounting hardware, make sure that no rust or buildup has accumulated between the mounting bracket for the light and the metal on the trailer.

You can also check the T-connection behind your right tail light on your 2007 Honda Ridgeline.

It is also possible that a connection might not be being made properly on one of the connectors, most likely the connector closest to the bulb.

Follow the green wire to the corresponding prong inside the connector and make sure that it is not bent. If you find that the prong looks good, I would make sure that your connectors are seated properly when you push them back together--make sure you hear the locking tabs click.

expert reply by:
0

Product Page this Question was Asked From


Q & A Icon

Similar Expert Q&A Pages

See More Q&A Expert Answers >>