bing tracking image
Q & A Icon

Trailer Running Lights Flash when Turn Signals are On

Question:

My wife brought home a 1987 or so Vanguard travel trailer she said all the exterior lights Worked and functioned properly this was last year. Now I went to go check out the camper and none of the lights worked. So I replaced all the exterior lightsthey Were all cracked and broken I tried matching the light fixtures up to the original ones other than the two front side running lights with leds also the two rear tail lights I replaced them with a dual filament bulb I also cleaned up all the connections and re did all the negatives. This got all the lights working. But now when I turn on the signal lights either the left or right all the running lights flash with the signal lights. I am stumped about this because the signal light wire s and running light wire are different wires. Any help would be much appreciated. Thanks.

0

Expert Reply:

Somewhere in the wiring the turn signal wire(s) is touching the running light wire. This is likely happening closer to the front of the trailer, perhaps at the connector but I would not rule out a short anywhere from the front to the back.

Also, by any chance does the wiring on the trailer side behind the trailer connector have 2 wires associated with just 1 pin? If so this is a wishbone harness. You would have one running light wire for the left side and one for the right side but they share the same pin at the trailer connector.

These wires are separate from the turn signal/brake light wires. What kind of connector does the trailer have? So things to check are: physical condition of the wires, fix any pinched frayed or broken wires, bad grounds (make sure all lights are ground to clean and corrosion free bare metal surfaces), and possible dirty or corroded vehicle and/or trailer side connectors.

expert reply by:
0

Product Page this Question was Asked From


Q & A Icon

Similar Expert Q&A Pages

See More Q&A Expert Answers >>