bing tracking image
Q & A Icon

Turn Signals and Brake Lights do not Work on Drivers Side

Question:

with running lights on it appears that the brake and turn signals do not work on only one side. With running lights off you can see the center rectangle illuminate for brake and turn. Have removed individual modules and swapped with other side. The modules are fine, problem is on drivers side. What would make only center rectangle light?

0

Expert Reply:

It sounds like the drivers side tail light wiring has a poor ground connection. When lights do not fully illuminate or work sporadically, a bad ground is the culprit almost 90 percent of the time. Try to trace the ground wire coming from the drivers side lights. If it is grounded to the chassis, I would try to relocate the ground wire to an clean bare metal surface. I would also use a new ground screw if the current screw is rusted or corroded.

If the ground wire is tied into the main trailer wiring, try to follow the wiring as far as you can to look for any weak connections. Since the problem is only on the drivers side, a loose connection would likely be before it ties into the ground wires for the other lights.

If you cannot locate a ground problem, I would try running a new ground wire from the lights all the way up to the main trailer ground. This will provide the most reliable grounding location on the trailer. If you do run a new ground wire, I would recommend using an appropriate length of 12 gauge wire like part # 12-1-1. You might find the trailer wiring help article that I attached helpful when trying to inspect your trailer wiring.

expert reply by:
0
John H

Products Referenced in This Question


Product Page this Question was Asked From


Q & A Icon

Similar Expert Q&A Pages

See More Q&A Expert Answers >>