bing tracking image
Q & A Icon

Brakes Do Not Work On Trailer After Replacing Wire Harness

Question:

i am trying to find out why i still have no brakes on the trailer after replacing the wire harness

0

Expert Reply:

It sounds like you are replaced the wiring harness on your vehicle or on your trailer and still having problems with no brakes. I have attached some helpful articles that explain brake controller installation and troubleshooting you can check out. The problems can run from incorrect harness, wiring, or fuses and relays all the way to the trailer wiring or the brake controller.

You will first want to make sure that the wire that leads from the trailer side 7-Way to the trailer brakes is located in the 7:00 position if looking at the face of the connector. If is not that could be why the vehicle is not recognizing that a trailer is connected.

You can also use a 12V power source and apply power directly to the trailer connector to see if the brakes engage.

There could also be a bad ground somewhere. I would start on the trailer and make sure that the main ground and the brake magnet grounds are attached to clean bare metal surfaces and corrosion free. Also, make sure there are no broken wires or that any wires are exposed and touching metal on the trailer frame.

If everything checks out, you can test the magnets. I have attached a link to a helpful article that explains how to test the magnets.

If none of these methods work you can let me know what kind of vehicle you are towing the trailer with so I can make some recommendations that may help. I would need the year, make, and model of the vehicle and also what wiring and brake controller you have installed.

expert reply by:
0
Jeffrey L


Video/Article/FAQ this Question was Asked From

Article or Video
Q & A Icon

Similar Expert Q&A Pages