bing tracking image
Q & A Icon

Troubleshooting No Running Lights on Camper

Question:

we have a 7 to 7 adapter.. We have electric brake works fine turn signals and brakes lights on camper but no running lights on the camper but park lights on the truck. What is wrong?

0

Expert Reply:

The first thing you are going to want to do is use a circuit tester like # 40376 if needed and test the connector on your truck to make sure all of the functions are working. If they are not use the owners manual and/or the legend on the power distribution box lid to find the locations of any fuses or relays related to the tow package wiring and replace any that are faulty.

Next test the adapter. This will tell you if there is a problem in the connector. If the problem is on the trailer, then a short on the running circuit is likely the problem.

A ground issue would typically only affect one or two lights, not all of the running lights on the trailer. But it is possible that it is a ground issue. The main trailer connector grounds and the grounds for each of the lights need to be attached to clean and corrosion free bare metal surfaces. On the 7-Way connector, check to make sure there is no corrosion built up where the wires attach.

If either trailer frame is aluminum or has a tilt bed or tongue then you will need to run jumper grounds from the lights to the main trailer connector ground.

Since you are using a 7-Way to 7-Way adapter you can also check to make sure the adapter is working properly by plugging it into the vehicle and using a circuit tester to test the 7-Way pins.

expert reply by:
0

Products Referenced in This Question


Product Page this Question was Asked From


Q & A Icon

Similar Expert Q&A Pages

See More Q&A Expert Answers >>