bing tracking image
Q & A Icon

Left Side Trailer Brake Light and Turn Signal Not Working But Wire as Constant 12 Volts

Question:

Left side B and I not working. Tested yellow wire for pulse signal for indicator but just getting straight 12 volts. Any suggestions

0

Expert Reply:

It sounds like there is a short to ground, ground problem, or a general short that is drawing 12 volt power all the time. The first thing to do is make sure the vehicle and trailer side connectors are clean and free of corrosion inside and out.

Ground problems normally show up when there is more draw on a system such as when you have the running lights on and then use another function like a turn signal or brake light but can show up any time.

The main connector grounds should be attached to clean and corrosion free bare metal surfaces. Also inspect the wiring on the trailer and vehicle and fix any pinched or otherwise damaged wires.

The light grounds on the trailer should also be attached to clean and corrosion free bare metal surfaces. If there is anything between a light ground and the metal trailer frame or if the trailer has an aluminum frame, tilt bed, or folding tongue, any of these things can interrupt the ground. Running jumper wires from the light grounds to the main trailer connector ground can help. I have included some articles that should also help troubleshoot.

expert reply by:
0

Product Page this Question was Asked From


Q & A Icon

Similar Expert Q&A Pages

See More Q&A Expert Answers >>