bing tracking image
Q & A Icon

Trailer Lights Work Off and On when Connected to a 2003 Chevy Trailblazer

Question:

I have a 2003 Chevy Trailblazer. It has several electrical issues, but the one that Im asking about is that of the trailer auxiliary. At times, I have towed trailers and never had any problems, but recently it seems the power from my vehicle to the trailer is intermittently functioning. Its very frustrating because I have connected the trailer to other vehicles to ensure the problem isnt my adapter, and it isnt. The problem lies somewhere in my 2003 Trailblazers electrical system. At times it will be working fine, but sometimes if I turn the car off and then back on again, the lights dont work, or only partially work. What is causing this? I removed the ground wire and cleaned the terminal with a wire brush. Everything seems to be in tact, and there are no corrosion or damage issues. I examined all the fuses in the vehicle, and there are no defects in them. My dash display also seems to have a glitch as well. I have a feeling that the two issues may be from the same problem, but Im not certain. Are there any known recalls, or reports from consumers in relation to this problem? Any insight would be greatly appreciated. Thanks

0

Expert Reply:

What you are describing is a ground issue most likely caused by a dirty or corroded trailer connector on the vehicle. Use a wire brush such as # 814113 to clean off corrosion on the pins. If you can take your vehicle side connector apart then check where the wires attach and clean/repair as needed.

You can also inspect the vehicle side wiring from the trailer connector forward on the vehicle and repair any damaged wires.

expert reply by:
0

Products Referenced in This Question


Product Page this Question was Asked From


Q & A Icon

Similar Expert Q&A Pages

See More Q&A Expert Answers >>