bing tracking image
Q & A Icon

Troubleshooting Possible Trailer Ground Problem on Jayco Pop-Up Camper

Question:

Converter a 6-pole square to 4-pole flat on an old Jayco popup I test all the wires individually and they are functional. When I secure all wire and turn the towing vehicle lights on only the running lights work. When I turn the running lights off only the turn signal works. When the running light wire is disonnected the brakes and turn signals work. Is there a way to repair the original, maybe soder a prong back? Thanks in advance...this is driving me nuts.

0

Expert Reply:

What you describe sounds like a ground problem. With the running lights on, full power is being sent through the lighting system and that's when the problem would manifest itself.

If the prong for the ground connection broke, it would certainly explain the problem you're having. If it's the actual prong from the connector that broke off soldering it wouldn't be strong enough, I'd recommend replacing the adapter with part # 30104.

Be sure to check the grounds on the pop-up as well. The trailer connector should ground to the trailer tongue. Make sure that connection is secure and not corroded. Make sure each trailer lamp is grounded either by being fastened directly to the trailer frame or by a ground wire directly linking the lamp to the trailer frame.

expert reply by:
0
Mike L

Products Referenced in This Question


Product Page this Question was Asked From


Q & A Icon

Similar Expert Q&A Pages

See More Q&A Expert Answers >>