bing tracking image
Q & A Icon

Troubleshooting Turn Signals When Using Magnetic Tow Lights TL21RK

Question:

I sent for these lights a couple months ago and finally got a chance to try them out. When I hooked them to my 7-way plug on the motorhome and tried the signal lights, both lights on the kit flashed at the same time. Is there a default in the lights because I had that plug hooked to my tow dolly before I sold it and the signal lights worked fine.

0

Expert Reply:

Thank you for your purchase of the Optronics Heavy Duty Magnetic Tow Lights # TL21RK. Since this kit uses a flat 4-pole type trailer connector I presume you're using some type of 7-way to 4-pole adapter, such as Pollak # PK12716, to connect the magnetic lights to your motorhome. There are a couple of potential causes for the problem you're having with both turn lights activating at the same time.

I suggest you carefully inspect all connectors for any signs of dirt, trapped moisture or corrosion. Such conditions can cause a short that could cause the lighting issue. I also suggest you check the main ground wire on the motor home harness. If the main ground is at all loose, or if the spot where it connects to the frame is corroded, this could cause the problem. A loose ground can cause many different types of faults with lighting.

If necessary apply an electrical contact cleaner like Caig De-Oxit to remove any corrosion from the 7-way and adapter contact surfaces. If the main motorhome ground point is rusty you can try cleaning off that spot with sandpaper, or you can re-locate the ground wire to a new spot that provides clean metal-to-metal contact.

Dielectric grease like # 11755 will help to protect all such connections by blocking entry of dirt and moisture that can over time degrade those contact surfaces.

expert reply by:
0

Products Referenced in This Question



Product Page this Question was Asked From


Q & A Icon

Similar Expert Q&A Pages

See More Q&A Expert Answers >>