bing tracking image
Q & A Icon

Troubleshooting Losing Turn Signal in Towed Vehicle When Headlights are Turned On in Coach

Question:

Hello, I purchased a complete system from you guys that included the base plate, road master Falcon and the easy brake. Im having an issue with my left turn signal on my 2015 wrangler. Everything works fine with the coach headlights off, but with them on I lose my left turn signal on the tow jeep. Everybody scratches their head when I explain the problem. Everything worked fine for about 6 months after install. Any help figuring out this issue would be helpful. Bad bulb, diaod? Thank you

0

Expert Reply:

Thanks for your business. I can certainly help you troubleshoot this issue with you.

From what you describe it sounds like you are having a ground issue. When you turn on your headlights you are drawing more amperage which if you have a bad ground can then start to cause issues.

First thing I would do is check the ground wire on the Jeep and make sure it's tightly mounted to a clean metal surface. If that doesn't fix the issue we need to identify where the issue is coming from. We will start with the Coach and work our way back connection to connection to see if the problem lies in the tow vehicle or the parts connecting the tow vehicle or the Coach itself.

To figure this out you can either plug in a known working tow vehicle/trailer with the Coach's headlights on and see if it behaves the same. If it does it is likely in the Coach's ground wire. Another way to do this would be to use a circuit tester like # PTW2993 and test the functions coming out of the Coaches 7-way wiring socket with the headlights on. If all the functions normal on the Coaches end, then we will want to move on to the wiring umbilical.

Plug the wiring umbilical into the Coaches 7-way socket and again test the functions that come out of the 4-pole on the other side. If the functions are not coming through then you know the problem lies within the umbilical. If the functions are normal then I would move to the 4-pole connector on the vehicle.

On the tow vehicle (Jeep) you will want to check for any wires that may have crossed connections within the plug. Even a single crossed wire thread from the different functions on the plug can cause issues.

If this does not result in a solution please let me know and I would be more than happy to further troubleshoot this issue with you.

expert reply by:
0
Jackie C

Products Referenced in This Question


Product Page this Question was Asked From


Q & A Icon

Similar Expert Q&A Pages

See More Q&A Expert Answers >>