bing tracking image
Q & A Icon

Troubleshooting Pins of 7-Way at Rear of 2003 GMC Sierra that Arent Active

Question:

I just got a 2003 GMC Sierra 1500 HD with the tow/haul option. It has a 7 way camper plug on it and I have no power there or on any of the fuses in the fuse boxes under the dash or under the hood. Ive read some forums and Ive checked for the wiring connections under the fuse box under the hood. The 30A fuse for the accessory #2 stud is good and there is power on that stud as well as the red wire going off of it. It had a brake controller in it when I purchased it and when I actuate the manual brake on the controller the brake lights come on and everything. I noticed there is a 5th wheel 7way plug in the bed pigtailed off of the other 7 way plug. I dont know if there is a relay somewhere that isnt activating these fuses or what. I have an electrical background but this kind of has me a little stumped. Not sure if this matters or not but the vehicle does have an aftermarket remote start on it as well. Thanks in advance.

0

Expert Reply:

First thing I would try is unplugging the 7-way you have installed in the bed of your truck. Unplug it from the 7-way that is at the rear of the vehicle and then connect the rear 7-way back up without the harness to see if that allows the pins on the 7-way to be active again.

Under your hood there would need to be some connections made. I attached a help article that covers that info for you to check out. The fuses could also be blown. Also, you can try checking the pins of the 7-way in your truck bed before unplugging it to see if the voltage happens to be there.

expert reply by:
0
Jameson C

Product Page this Question was Asked From


Q & A Icon

Similar Expert Q&A Pages

See More Q&A Expert Answers >>