bing tracking image
Q & A Icon

One Side of Trailer Brakes Work But Other Side Does Not But Uses Same Wire

Question:

The trailer brake wire run down left side of trailer, connects to left side brakes then run through axles to right side and connects to right side brakes. the funny thing is the right side brakes work fine but left side do not and its really the same wire. Have replaced complete brake assembly on both sides. This is the factory wiring. Why would left side not work and right side is OK when wire goes to left side first?

0

Expert Reply:

It sounds like the left side may have a bad ground in the system or a loose ground. I would check over the complete wiring system and make sure all grounds have a good metal contact and no rust.

Also check the wires to make sure the protective coating is not worn and that there are no bare wires exposed.

The connector from the vehicle to the trailer could also be corroded, you will want to check inside the connector to make sure. If there is not corrosion, it would be a good idea to apply some dialectric grease, part # 11755, to prevent corrosion in the future.

After checking over the grounds, wiring, and connectors, I would check the brake magnet on the left side. You will have to remove the drum, and check for abnormal wear or windings on the magnet, if that is the case the magnet will need to be replaced. If you have already replaced the magnets with a new ones, then there is a greater chance that there is a bad ground.

I have linked a video below that includes the replacement of brake magnet that you may find as a good reference.

expert reply by:
0

Products Referenced in This Question


Product Page this Question was Asked From


Q & A Icon

Similar Expert Q&A Pages

See More Q&A Expert Answers >>