bing tracking image
Q & A Icon

Screen on Prodigy Brake Controller Goes Blank When Braking a 2002 Chevy Suburban

Question:

I have a 2002 suburban with the tow package and have installed the controller with an available harness. Everything seems to be ok as I do not get any error messages. With the trailer connected, I have set the the controller to 6.0 as per the instructions and at 25 mph fully applied the manual knob and can feel the trailer braking. But when I apply the vehicle brake, there is no readout on the controller or brakeing by the trailer. The trailer brake lights do work when I apply my vehicle brakes. Thanks

0

Expert Reply:

A blank display when engaging the manual or vehicle brake usually indicates that you are losing power on either the power or ground wire for the brake controller.

Did you use the # 3025-P plug-in brake control wiring adapter when you installed the unit on your 2002 Suburban? If so, I would first make sure the connections are firmly seated--push together until you hear the click. You can also check the wire itself to make sure there are no pinched or exposed points that might be touching metal and causing a false ground.

If you are using the incorrect plug-in adapter for your 2002 model, this would also be a possible cause for the problem. For example, if you are trying to use plug-in harness # 3015-P, which is for the 2003 through 2006 Suburban models, the red brake switch wire would not be located on the same pin, and would thus not get a reading when you press your brake pedal.

The easiest way to test for this would be to use a circuit tester to see if the red wire on your brake controller harness is getting power when you press the brake pedal. If not, you would know that the pins on the harness do not match up exactly with your factory brake controller port.

expert reply by:
0

Product Page this Question was Asked From


Q & A Icon

Similar Expert Q&A Pages

See More Q&A Expert Answers >>