bing tracking image
Q & A Icon

Trailer Running Lights Slowly Pulse On and Off and Rear Tail Lights Not Working w/Mercedes Sprinter  

Question:

I have 2012 chassis, MB sprinter 3500, 2013 Airstream Interstate RV. bought this replacement plug but not working. Trailer running lights slowly pulse on and off, no tail lights, but brake and blinkers work. strange. cant figure it out.

0

Expert Reply:

The tail lights on the back of a trailer run off of the running light circuit so the fact that the other lights on that circuit are working and most of the problems are just at the rear tail lights that makes me think there is a ground problem.

Ground problems normally show up when there is more draw on a system such as when you have the running lights on and then use another function like a turn signal or brake light but can show up any time.

Make sure that the vehicle side and trailer side connectors are clean and free of corrosion inside and out. The main connector grounds should be attached to clean and corrosion free bare metal surfaces.

The light grounds should also be attached to clean and corrosion free bare metal surfaces. If there is anything between a light ground and the metal trailer frame or if the trailer has an aluminum frame, tilt bed, or folding tongue, any of these things can interrupt the ground. Running jumper wires from the light grounds to the main trailer connector ground can help.

If the lights on the trailer are LED lights then the problem could be that they do not have enough power draw and are confusing the tow package system on the Sprinter. This is more common on Mercedes and other German vehicles but there is a solution. You can add more load using a special adapter, # C57003.

expert reply by:
0

Products Referenced in This Question


Product Page this Question was Asked From


Q & A Icon

Continue Researching

See More Q&A Expert Answers >>