bing tracking image
Q & A Icon

Brake and Turn Signals are not Working when I Connect the # 40455 Harness to my 2007 Ford Escape

Question:

After connecting part# 40455 to the connector on my 2007 ford Escape. The only lights that were working was the tailight. There were no brake lights or turn signal lights. What will be something that I can do to get this working right.

0

Expert Reply:

You will want to make sure that your 2007 Ford Escape has the factory tow package. If the vehicle did not come with a factory tow package the connector should still be there but the wiring may not be completed to the front of the vehicle.

You might call the Ford dealer and if you give them your VIN number they should be able to tell you if you have the factory tow package and if you will need any additional fuses or relays in the fuse block to activate the tow package.

If you do not have the factory tow package you will need to use the Tow Ready T-One Wiring Harness, # 118426. This harness will plug into the back of your taillights and an additional wire must be ran to the battery at the front of the vehicle to power the trailer lights. This harness has a Modulite which protects the tow vehicle from any electrical shorts or any mis-wiring problems.

I am sending a link to the installation instructions of the Tow Ready wiring harness.

expert reply by:
0
Jameson C

Products Referenced in This Question


Product Page this Question was Asked From


Q & A Icon

Similar Expert Q&A Pages

See More Q&A Expert Answers >>