bing tracking image
Q & A Icon

Troubleshooting the Left Turn Signal Not Working on Trailer

Question:

The wiring in my utility trailer seems to have a mind of its own. Everything works, except for the left turn signal. Ive checked and re-secured each connection on the trailer, checked the connection to my car, even hooked up a different trailer to my car to verify it wasnt the cars wiring that was the issue nope!. Ive looked through multiple online forums, only to find the same answers possibly a bad ground? and checked that over without any luck. What else should I be checking???

0

Expert Reply:

It sounds like you have checked just about everything there is to check. Since you said that you have checked all of the connections and tried a different trailer with your vehicle and it worked fine, the only other thing that I can think of is for you to check the wiring itself.

Start on either of end the trailer and follow the wiring that goes to your left turn signal. Check for any corroded, exposed, bent, or damaged sections. If that all looks fine, then (if you can without damaging it) you could try to see if the wiring in the housing of the light is damaged somehow.

Other than that, the only other thing that I can think of is to just run some new wire. You can use 16 Gauge Wire, part # 16-1-1 and some Butt Connectors, part # 05731-5, to accomplish this.

If you were unable to take apart the light itself, and if you replace the wiring and the problem still exists then you can try replacing the light. If it comes down to this option, just let me know the dimensions of the light that you will need and I can make some recommendations for you.

expert reply by:
0
Jon G

Products Referenced in This Question


Product Page this Question was Asked From


Q & A Icon

Similar Expert Q&A Pages

See More Q&A Expert Answers >>