bing tracking image
Q & A Icon

Troubleshooting Running Lights on Trailer Towed by 2014 Nissan Armada

Question:

All lights are working on the trailer except the running lights. checked the 2 blue and brown relay and seemed to be working, could not find any other fuse or relay that power the running lights. Fuse box do not label trailer lights or some thing to refer to the trailer besides the small fuse box in front of the big box that has the two blue relays and the brown. checked under the dash board and did not see any fuses or relays.

0

Expert Reply:

Most of the time, when trailer running lights do not work but all other lights do work properly the cause is a weak ground connection. Since running lights stay on continuously, unlike stop/turn lights, they draw more current and a weak ground may allow the other functions to operate correctly but not pass enough continuous current for the running lights.

The fix is simple in this case. Find your trailer's main ground wire (and do the same thing on the wiring harness on the Armada) and ensure it is solidly affixed to clean bare metal. A good ground needs clean metal-to-metal contact.

You can move the ground wires if necessary to a new spot on the frames, just make sure that new grounding point is sanded clean to remove paint, primer, undercoat, rust, grease, etc. You can protect your new ground connections with dielectric grease # 11755. This will help block water and contaminants from entering the connection.

expert reply by:
0

Product Page this Question was Asked From


Q & A Icon

Similar Expert Q&A Pages

See More Q&A Expert Answers >>