bing tracking image
Q & A Icon

Driver Side Trailer Lights Not Working with T-One Vehicle Wiring Harness, # 118426 2006 Ford Escape

Question:

I have a T-connector that has a power wire directly to veh battery. When I hook the trailer up to the veh, the only thing that works is the right turn signal and brake light on the right side. I know there is nothing wrong with the trailer end of things because I can provide a direct power source to the trailer and all lights work fine so I know it is on the veh end. When I check power at the connector I find 11.8-ish volts on each terminal no matter if it is activated or not. There is power coming down from the lights to teh junction box but some how it is not getting to the trailer. Any help on how to diagnose or what the problem could be would be appreciated.

0

Expert Reply:

If you are getting the correct signals at the vehicle side trailer connector when using T-One Vehicle Wiring Harness, # 118426, then there is most likely a ground problem somewhere. It is probably not on the wiring harness since it grounds through the T-connectors. To be sure I would go ahead and make sure all the connections are made and secure.

Next, you can check the main ground from the trailer side connector to the trailer frame. It will need to be connected to a clean and corrosion free bare metal surface on the trailer frame. If there is any dirt or corrosion on or in either trailer connector, you will want to clean that out too.

Last you will want to check the grounds for the trailer lights themselves. Trailer lights usually ground through the mounting studs and they will need to be attached to a clean and corrosion free bare metal surface. If you are still having a problem it is possible that there is something wrong with the converter.

To check the converter, test the signals going in and the signals coming out of the converter box using circuit tester # PTW2993. If they are different, you know you have a problem with the converter, and it will need to be replaced. If the signals are correct and the problem persists, there is a wiring problem somewhere between the converter and taillights that you will need to track down.

expert reply by:
0

Products Referenced in This Question


Product Page this Question was Asked From


Q & A Icon

Similar Expert Q&A Pages

See More Q&A Expert Answers >>