bing tracking image
Q & A Icon

Odd Voltage Readings and Malfunctioning Trailer Lights w/Curt Harness Installed on 2004 Lexus RX330

Question:

2 year old Curt powered tail light converter installed on Lexus RX330. Boat trailer lights worked fine until recently. Now tail lights work but turn/brake lights do not work. Tested trailer on other vehicle and everything works correctly. Multimeter showing 18v on tail light pin but only 2 volts on yellow and green wires. Any ideas? What would cause 18v reading?

0

Expert Reply:

It sounds like the converter box may have shorted out, which can cause high and low voltage readings. To verify this, you will want to test the power going into and out of the converter box. If all power readings are fine going into the box but not coming out of the converter, then we'll know it is a problem with the box and not an issue with your Lexus. I've provided a link to our article on troubleshooting 4 & 5-way wiring installations which may be helpful.

It is most likely a short on the trailer's wiring that is responsible for shorting out the converter, so you should inspect the trailer wiring to look for the short before installing a new harness like # C55563. I've attached a video that will show how to find and fix wiring shorts. If you decide to replace your trailer wiring, I would recommend going with the Hopkins Endurance Trailer Wiring Harness, # HM48240. We used this kit recently to replace wiring on our trailer and I love the ergonomic grip on the connector which makes disconnecting much easier.

If you have additional questions, I am happy to help.

expert reply by:
0

Products Referenced in This Question


Product Page this Question was Asked From


Q & A Icon

Similar Expert Q&A Pages

See More Q&A Expert Answers >>