bing tracking image
Q & A Icon

Trailer Brakes are Not Working Properly With Both Wires Run to Battery for Power

Question:

I was having problems with my trailer brakes so I decided to hardwire it to a battery on the two wires that come out the back of the break when I do this I get a small spark at the battery connection but hear nothing from the brake and no movement. I removed the brake drum and nothing seems out of place all wires still have plastic coating nothing is grounding out .

0

Expert Reply:

Trailer brakes like part # 23-26 in your picture have 2 wires coming out from them. To properly install them you need to connect one wire to your trailer brake controller circuit (unless you are testing them like what you are doing) and then the other wire needs to have a clean solid ground. It doesn't matter which is which, but since you don't have one grounded that is your problem.

As far as your trailer brakes go if you can let me know what the problem was that you were having I can help you pinpoint what needs to be done.

Sometimes trailer brakes just simply need to be adjusted using a Brake Adjustment Spoon # W80630 and other times the Trailer Brake Magnet # BP01-110 may be bad. I have attached a link to a help article that shows how to test your brake magnets for proper function. If they are not working correctly then the brake magnet part I referenced is what you need to replace them.

click to enlarge
expert reply by:
0
Jon G

Products Referenced in This Question



Product Page this Question was Asked From


Q & A Icon

Similar Expert Q&A Pages

See More Q&A Expert Answers >>