bing tracking image
Q & A Icon

Brakes On Trailer Stop Engaging When Using Tekonsha Prodigy Brake Controller

Question:

loss of braking on way home. no er diplayed but 0.0 up on diplay ,even though i adj,d to 6.3 level as instructed. display message means controller set at 0 ???? please help ! thanks

0

Expert Reply:

I would begin by checking the connections on the back of the brake controller. You will want to make sure none of the wires have become disconnected or that there are not any bad connections. It sounds like the Blue wire which sends power to the trailer brakes may have a bad connection somewhere. I would start by cutting the blue wire a few inches from the brake controller and see if you get signal. If you do get signal, the Blue wire may have a bad connection somewhere. If you do not get signal, the brake controller may be faulty and will need to be replaced. You will want to use a circuit tester, part # 40376.

There may also be a bad stop light switch connection, which is the red wire that detects the brake pedal is being pressed. What you can do is use the manual lever to activate the brakes. If the manual lever activates the brakes, it could be that the red wire has a bad connection.

I would also inspect the wiring on the trailer. Make sure that the wires going to the brake assembly are connected and have not been cut or damaged. Each brake assembly should have a good, clean ground connection.

Yes, when the display reads 0.0, that indicates that the power level is set at 0. If you find that all the wires are connected, I would recommend unplugging the brake controller and plugging it back in. When you unplug the controller, the settings will be erased and you will have to setup the controller like you did when it was initially installed.

I have linked instructions and a video on diagnosing brake controller problems.

expert reply by:
0

Product Page this Question was Asked From


Q & A Icon

Similar Expert Q&A Pages

See More Q&A Expert Answers >>