bing tracking image
Q & A Icon

Troubleshooting Wiring Connection When Vehicle and Trailer Both Work But Not Together

Question:

Got 2011 Kia Sportage put a trailer harnes on it but only one light on the side of trailer works cant get the stop lights or any other lights to wor when I plug the trailer into my van the lights all work so whats going on the trailer has a bran new harness on it and also I have a plug in tester that plugs into the car harness and it all checks out fine but when I plug the trailer into the Kia it wont work

0

Expert Reply:

It sounds like a common ground wire issue. Since everything on the vehicle checks out and everything on the trailer checks out and both work independently, the issue is with a ground wire most likely on the trailer. The reason why the trailer works with another vehicle without issue is simply because that vehicle is able to supply more power to help mitigate a ground connection that can be improved.

My recommendation is to start with the trailer ground connection and make sure it is bare metal to metal without any corrosion, debris, and even paint. Then try your combination to see if it solves the problem. If not, try a different ground connection and then try a different wiring harness ground connection on your vehicle if that second ground location still doesn't solve the problem.

Using some dielectric grease # 11755 in your connections also helps by keeping moisture and debris out.

expert reply by:
0

Product Page this Question was Asked From


Q & A Icon

Similar Expert Q&A Pages

See More Q&A Expert Answers >>