bing tracking image
Q & A Icon

Trailer Lights Not Working when Connected to 2008 Honda Odyssey

Question:

Hello, I recently bought the T1 connector for my Honda Odyssey and connected it with ease however it does not power the lights on my trailer when I use a tester it says that everything is correct it lights up the little tester with all signals brakes and running lights but when I connect to trailer, it will not light up the trailer lights. I know that the trailer lights and wiring is okay on the trailer because it works okay on another vehicle off mine...any help will be much appreciated. Thank you

0

Expert Reply:

Not all trailer wiring harnesses are created equal. By that I mean that if there is a weak ground on the trailer side it could work with some but not all vehicles. Also depending on how many lights the trailer has it is possible that it is overdrawing harness # 118438 on your 2008 Honda Odyssey. This particular harness is rated for 2.1 amps per circuit for brake and turn signal lights and 4.2 amps for the running lights.

Also you will want to make sure that the wiring harness white ground wire is attached to a clean, bare metal surface. You may need to move the ground location on the vehicle.

Make sure that the vehicle side and trailer side connectors are clean and free of corrosion inside and out. The main connector grounds should be attached to clean and corrosion free bare metal surfaces.

The light grounds should also be attached to clean and corrosion free bare metal surfaces. If there is anything between a light ground and the metal trailer frame or if the trailer has an aluminum frame, tilt bed, or folding tongue, any of these things can interrupt the ground. Running jumper wires from the light grounds to the main trailer connector ground can help.

expert reply by:
0

Product Page this Question was Asked From


Q & A Icon

Similar Expert Q&A Pages

See More Q&A Expert Answers >>