bing tracking image
Q & A Icon

Troubleshooting Weak New Brakes on Trailer Rear Axle

Question:

I recently installed four new Dexter self adjust brake assemblys, with four new Dexter drum assemblys. I performed the initial manual brake adjustments and after forty to fifty miles of on and off braking, the rear or second axle brakes dont really seem to be working very well. I turned the gain up high on my controller and had someone watch as I used the manual over ride, the rear axle doesnt do much. I even triple checked the wiring to ensure the proper voltage is going to the assemblys and it is. If you have any recommendations I would greatly appropriate it. Thanks!

0

Expert Reply:

Since it sounds like you performed the initial brake adjustment correctly and have given them a bit of time to self-adjust by simply pulling the trailer, the issue you are having may be coming from a weak ground. I recommend checking both brake assemblies on the rear axle to make sure the ground wires are securely connected to a clean, bare metal surface on the trailer frame. Make sure there aren't any exposed areas on the wiring around the assemblies that need to be replaced.

Also just be sure that the brake assemblies are installed on the correct sides (left/right). The magnet should always be on the bottom of the assembly and the actuating arm will always bow toward the front of the trailer.

If this does not resolve the issue please let me know and I will be happy to look into this further.

expert reply by:
0
Chris R

Product Page this Question was Asked From


Q & A Icon

Similar Expert Q&A Pages

See More Q&A Expert Answers >>