bing tracking image
Q & A Icon

Troubleshooting Trailer Connector Not Working on 2015 Kia Sorento

Question:

Hi I have a Kia Sorento 2015 V6 that i bought a CURT brake light module for 2 or 3 years ago. The trailer and car have worked properly no problem. All of a sudden on one of our last trips the lights on the trailer stopped working. I cleaned the ground and contacts on the connector, still no lights. Lights on the car work properly. The right brake and directional lights off of the connector work intermittently. The left brake and directional light dont work at all. I have tested it with both the trailer and a set of those magnetic brake lights. So its not the trailer. The car lights work so its not the car. I even bought a new CURT module and harness and the problem still exists. So its not the CURT harness. In the end its between the connection of the CURT harness and however that interfaces with the brake light control system. Is there something else on the car that feeds where the CURT harness plugs into that could be the problem? Id appreciate any advice you offer.

0

Expert Reply:

Since you have tried a couple of the Curt T-Connector Harnesses # C56332 on your Kia Sorento and have also ruled out the trailer wiring as being the issue, the problem as you mentioned is coming somewhere along the factory trailer wiring starting at the port that connects to the Curt harness. I recommend tracing that wiring as far as you can to see if you can find any exposed or damages areas that need to be replaced. Also check for any blown fuses or relays on your Sorento related to trailer towing, which will be listed in your copy of the owner's manual.

If everything looks good, your best bet is to take the vehicle up to a local Kia dealer and have them inspect the factory wiring.

expert reply by:
0
Chris R

Products Referenced in This Question


Product Page this Question was Asked From


Q & A Icon

Similar Expert Q&A Pages

See More Q&A Expert Answers >>