bing tracking image
Q & A Icon

Troubleshooting Lights Not Working on Camper Trailer

Question:

Only the front to running lights work on 2006 Fleetwood Niagara. The rest of the running lights in the back the brake lights and turn signals do not work

0

Expert Reply:

There are a number of reasons why many of the lights on your 2006 Fleetwood Niagara so in order to determine the specific problem you will need to use a circuit tester such as # 40376 to test the connector on your tow vehicle after disconnecting it from your trailer.

Check the wiring going into your harness from your tail lights to see if those wires are carrying the correct signals, if not then the issue is with the vehicle wiring. If the signals going to your harness are okay, you'll need to test the signals coming out of the harness, and if they are correct then your issue is likely going to be with the trailer side wiring.

You will also want to check both your vehicle and trailer connectors for corrosion, which can be green or white in color. A build-up of corrosion can interfere with the signals getting through the connectors so if it is present you will need to either replace the plug or clean the corrosion and be sure to use Dielectric Grease # LT37534 in the future to help stop any future corrosion.

An important issue you will want to take a look at are the ground connections, as they can be the cause of numerous lighting problems. You'll want to make sure your grounds are securely attached to bare metal surfaces free of any paint, dirt or corrosion of any kind.

Also check your wiring thoroughly to ensure there are none that are crimped, broken or otherwise damaged. I've added links to a pair of help articles on trailer wiring that you may also find useful.

expert reply by:
0
Kyle S

Products Referenced in This Question



Video/Article/FAQ this Question was Asked From

Article or Video
Q & A Icon

Similar Expert Q&A Pages