bing tracking image
Q & A Icon

Troubleshooting Trailer Turn/Brake Signal Not Working on a 2014 Toyota Tundra

Question:

Hey guys, I have a 2014 Toyota Tundra with factory tow package, just the other day when I hooked up to my trailer my turn signal/ brake lights didn’t work on the trailer, but they work on the truck. I still have running lights and my electric brakes work on both my enclosed trailer and dump trailer through the 7 pin plug. I also tried my small utility trailer through the 4 pin plug and had the same problems. I have checked every fuse in the truck both in the engine bay and under the dash and all fuses are in working order. I also tried switching relays out to the trailer relay and that didn’t work either. I put a volt meter onto the 7 pin truck side connector and I have 12v running to my running lights, brakes, aux power. For some reason I only have 10.5v running to both the left stop/turn and right stop/turn pins and I cannot figure out why. I have also hooked all three trailers up to a friends truck and all lights work properly. Any help would be greatly appreciated. Thanks

0

Expert Reply:

Thank you for all of the details, you have already done quite a bit of the work in narrowing down the problem. Since the common denominator in this situation is your 2014 Toyota Tundra the issue can be isolated to that.

You should be getting 12V of power to your stop/turn lights so since that is lower you most likely have a ground issue. Check the ground on your Tundra as well as the wiring for those light circuits. You should find a bad ground or some wiring that has been pinched or damaged.

If you make sure that your ground is securely connected to a clean, bare-metal surface and replace any damaged wiring with 16 gauge wire like part # 16-1-1 and butt connectors # DW05744-5 than your problem should go away.

expert reply by:
0
Jon G

Products Referenced in This Question


Product Page this Question was Asked From


Q & A Icon

Similar Expert Q&A Pages

See More Q&A Expert Answers >>