bing tracking image
Q & A Icon

Troubleshooting Remote of Fan-Tastic Roof Vent 7350 Not Operating Fan

Question:

Our fantastic fan, model 7350 remote does not communicate with the fan. The fan works on high speed when the vent is manually raised, the lights all work when the buttons are pushed, but nothing changes on the fan. I have installed new batteries, checked to make sure they are installed properly, held the remote right next to the installed fan, but still no change in the fan speed or anything else when I try to change anything remotely. The remote control worked as it should for the past year. Any suggestions as to what else I can try?

0

Expert Reply:

Have you tried reprogramming the remote? For programming a Fan-Tastic roof vent remote like part # FV9068-09 which is what your 7350 fan part # FV807350 uses what you need to do is hold your remote 12 inches away from the fan while holding both arrows. The Auto and Manual lights will begin flashing immediately. Continue holding both arrows down until the seven LED's flash once. Now it's programmed.

You may have to try both sets of arrows, the speed and temp ones.

If this does not work or you can't get the remote to program then it's most likely damaged and you'd want to replace the remote.

expert reply by:
0
Jameson C

Products Referenced in This Question


Product Page this Question was Asked From


Follow up Questions


Al W.
Re 7350 Remote Fantastic Fan Controler. Changed batteries. LED’s light up on face. No beep indicating fan has received signal. Should the bulb? light up (at top end of control near on/off button) when buttons are pressed? Haven’t tried reprogramming yet. Is there a way to turn on fan manually? Your help would be appreciated. Thanks,
Etrailer Expert
Reply from Jon G.

I would try reprogramming it like Jameson mentions above. If that doesn't work then I can help you look into this further.

Reply from Michael M.

@JonG my fan suddenly stopped responding to the remote. I tried reprogramming it and nothing happened on the remote or with the fan. I can manually open the fan all the way but nothing happens. I don't know why the motor would go out or fuse would blow, I barely use the fan and it's fairly new. Any suggestions? I'm hoping it's the remote, but the lights turn on when I press the buttons and it has new batteries.

Etrailer Expert
Reply from Jon G.

@MichaelM Try selecting the manual operating mode with the controller and manually opening up the vent lid all the way prior to programming the remote. Are you able to use the knob on the vent housing to turn the vent on?

Reply from Michael M.

@JonG when I twist the knob to open the vent all the way it does not turn the fan on. I put the remote on manual and tried to program after opening vent but still no response from fan and no blinking lights on the remote. I just can’t figure out why it stopped working all of a sudden. What would a blown fuse look like?

Etrailer Expert
Reply from Jon G.

@MichaelM Since it isn't working even with the manual knob that means the issue is on the fan itself. To replace the fuse you will need to take that black knob and turn it 1/4 to 1/2 turn counter-clockwise while gently pulling down. This should reveal a 4 amp slo-blo fuse. You should see the filament on the inside looking broken or damaged. You'll want to check your wiring too to make sure that none of it is damaged and that your ground is securely connected to a clean, bare-metal surface. Any of this could cause the fuse to blow.

Reply from Michael M.

@JonG perfect thank you. I’ll check it out and get back to you if all that checks out.

Reply from Robert S.

@JonG - I am having a similar issue. Fan remote continues to not work when power is turned off to fan for storage. I reprogrammed the remote a couple times, but that no longer seems to work. I can use the manual black knob to open/close vent, but no way to turn fan on/off. Fuse looked good last time I checked. Any other ideas. I purchased this model for my custom stacker trailer and have to climb a ladder to open/close manually is a PIA. Can you add a hard wired remote to the 7350? So frustrated. Everything worked for the first few months and has been a problem since.

Etrailer Expert
Reply from Jon G.

@RobertS Are you saying that you have removed power completely from the vent? If not I would try that first. If your fuse looks good then removing power completely should give you a hard reset and you can try connecting the remote from there.

Q & A Icon

Similar Expert Q&A Pages

See More Q&A Expert Answers >>