bing tracking image
Q & A Icon

Troubleshooting Running Lights Not Working on Keystone RV Trailer

Question:

Im trying to get my 2014 Keystone Cougar 33foot RV road ready. When I check my lights Ive got brake, turn, and 4-way flashers, but no run/mark/clearance lights. Ive done a continuity test on the 7-pin trailer connector and one terminal is open. What could be wrong?

1

Helpful Expert Reply:

There are many, many different reasons why your lights could not be working. In many cases a bad ground is to blame for this type of issue, but in order to determine the specific problem you will need to use a circuit tester such as # PTW2993 to test the connector on your vehicle after disconnecting it from your trailer.

Check the wiring going into your harness from your tail lights to see if those wires are carrying the correct signals, if not then the issue is with the vehicle wiring. If the signals going to your harness are okay, you'll need to test the signals coming out of the harness, and if they are correct then your issue is likely going to be with the trailer side wiring.

As I mentioned above, an important issue you will want to take a look at are the ground connections, as they can be the cause of numerous lighting problems. You'll want to make sure your grounds are securely attached to bare metal surfaces free of any paint, dirt or corrosion of any kind. Also check your wiring thoroughly to ensure there are none that are crimped, broken or otherwise damaged. I've added links to a pair of help articles on trailer wiring that you may also find useful.

helpful expert reply by:
1
Jameson C

Products Referenced in This Question


Product Page this Question was Asked From


Q & A Icon

Similar Expert Q&A Pages

See More Q&A Expert Answers >>