bing tracking image
Q & A Icon

Trailer Wiring Troubleshooting  

Question:

ford diesel 2007 f-250. i have rewired all my trailer lights and brake wiring. It is a 24 volt system from what i found on meter. yesterday i had good voltage to the truck plug at all points. electric brakes, aux, running lights, Lt and Rt. Today when i finished. I have no power at the electric brake pin and then later lost it at the Rt and Lt points. Fuses good. What am I missing. Thank you

0

Expert Reply:

Since you have already checked that your fuses are good and you are otherwise not getting a signal to the plug on your 2007 Ford F-250 you will need to do some basic troubleshooting.

Start by checking to make sure the wires are fully seated in your truck's trailer connector; if they are not that would explain why you were not getting a signal when you tested it. Also check both your connector for corrosion, which can be green or white in color. A build-up of corrosion can interfere with the signals getting through the connectors so if it is present you will need to either replace the plug or clean the corrosion.

You'll also need to make sure your grounds are attached to bare metal surfaces and free of any paint, dirt or corrosion. Finally, check your wiring thoroughly to ensure there are none that during the installation process were somehow crimped or damaged.

I have added links to a pair of help articles on trailer wiring, including a troubleshooting guide which I highly recommend taking a look at.

expert reply by:
0
Kyle S

Product Page this Question was Asked From


Q & A Icon

Continue Researching

See More Q&A Expert Answers >>