bing tracking image
Q & A Icon

2015 Land Rover LR4 Trailer Icon Disappearing When Towing Trailer with LED Lights

Question:

Hi, my 2015 LR4 has factory installed tow package has both 7 and 4 pin. the cargo trailer 7 pin is equipped with LED lights. when i hook up the trailer to LR4, everything works fine on trailer side all LEDs work properly, no flickering anything, electric brakes work too . BUT, here comes the problem on LR4 side: the rear sensors on vehicle wont disable when i put the car in reverse and the green trailer icon in the instrument panel not shown when the vehicles turn signals are operated. so, I searched and tried Curt # C57003 Adapter, it turned out no luck, still didnt work on vehicle side. trailer side no problem at all. so do you have any suggestion please? Thank you

0

Expert Reply:

It sounds like the 7-way on your 2015 Land Rover LR4 is not getting the signal that the trailer is connected at times, which you are correct, is due to the LED lights on your trailer, and the fact that they have such little power draw. That means the 7-way is not "recognizing" the trailer connection when you are in reverse or signaling. The 7-Way Trailer Adapter for Towing Trailers with LED Lights # C57003 was a good idea, but if that did not work the next option I suggest is to add LED Light Bulb Load-Resistors # DI34ZR because it doesn't rely on an adapter working correctly.

Should that not work it may be possible for you to manually disconnect the rear sensors, though that would be something that you would need to visit your Land Rover dealer about (which is not ideal, I fully realize) in order to determine if this is possible and/or how it could be done.

click to enlarge
expert reply by:
0
Kyle S

Products Referenced in This Question


Product Page this Question was Asked From


Q & A Icon

Similar Expert Q&A Pages

See More Q&A Expert Answers >>