bing tracking image
Q & A Icon

Running Lights Do Not Work on Yakima Rack and Roll Trailer Pulled with a 2008 Saturn Vue

Question:

I have a 2010 Yakima Rack N Roll trailer. The trailer running lights do not work, while all other functions do. Is there an easy fix? My tow vechicle is a 2008 Saturn Vue.

0

Expert Reply:

The first step I would take is to check the vehicle side and trailer side connectors for any corrosion or dirt build up that could cause a bad connection and clean it out.

If the connectors look clean, then you should use a circuit tester, # PTW2993, to check the trailer connector on the back of your 2008 Saturn Vue. Make sure you are getting a signal at each pin when that function is activated. I have attached a video of my co-worker testing a 4-flat trailer connector for you to reference.

If the vehicle side trailer connector checks out okay, then we know the problem is on the trailer. On the trailer, you will want to make sure all of your ground connections are clean and corrosion free and follow the brown taillight wire checking for any damaged or frayed sections.

I have attached a wiring article as well as the assembly video for the Rack and Roll Trailer for you to check out. If you continue to experience the issue, then let me know what you come up with so we can take further troubleshooting steps.

expert reply by:
0
John H

Products Referenced in This Question


Product Page this Question was Asked From


Q & A Icon

Similar Expert Q&A Pages

See More Q&A Expert Answers >>