bing tracking image
Q & A Icon

CR-018 Skull Hitch Cover With LED Lights is Tripping Errors When Connected to a 2017 Ford Escape

Question:

Hello, I purchased the CR-018 Skull lights, but I get a BLIS error when I connect this to the 4 pin hitch lights connector, I have a Ford Escape 2017 Tatinun, I saw that converter 118158 could help me to solve my problem but I am not sure. I would like to know what you recommend. My guess is that the system is not recognizing the load of the LEDs. Thank you

0

Expert Reply:

This is a pretty common occurrence with the Ford F-Series trucks, but can also pop up on their SUV lines as well.

If you have an aftermarket wiring harness installed, like the Tekonsha # 118715, you will first need to check the ground connection. If this is not secured to bare metal with a solid, secure connection, it can cause all sorts of issues. From there you will need to test the ports on the 4 Flat with something like the # 40376. If the converter box on the # 118715 is malfunctioning, it may also be the cause of the error.

If your 2017 Escape was pre-wired from the factory with a towing package, LED accessories like the # CR-018 can trip some of the errors. This will sound odd as you already have a working 4 Flat plug, but if you splice something like the Curt # C58044 directly to the wires that handle the brake and flasher functions, it will bypass the system that is causing it to trip the error. This is most likely what you will need to do to get rid of the error and have everything work properly.

expert reply by:
0
Lazer S

Products Referenced in This Question





Product Page this Question was Asked From


Q & A Icon

Similar Expert Q&A Pages

See More Q&A Expert Answers >>