bing tracking image
Q & A Icon

Troubleshooting A MaxxAir MaxxFan 4050K That Won't Run

Question:

I have a maxxair maxxfan-smoke model number 4050K that worked well for 2 months. When I try to turn it on, it runs for 5 seconds, then shuts off with ten loud beeps, and green light blinks. The controls are dead, and no response from the fan, until I disconnect power, and reconnect. Then I can turn it on again, and the same process...so I bought a new circuit board a 10B21275KZ of note the prior circuit board was a 10B212756KZ, connected it, and the same thing happened. Is the problem not the circuit board? I am using a 12V 35AMP Deep Cycle Battery, and a 80 watt solar panel. The solar controller says the charge does go has high as 14.2 volts, could this be overwhelming the battery?

1

Helpful Expert Reply:

The first thing you should do is check is to make sure you have the wiring correct and not reversed. The white wire should be grounded and black to 12 volt power. If the wiring is correct make sure it's getting 12VDC power and the connections are good. With your MaxxFan Plus Roof Vent # MA00-04500K being so new it sounds like a wiring or power issue to me. The solar power charging your battery shouldn't be affecting your fan and if it was it would also be affecting anything else running off of DC power.

The correct circuit board for a 4050K is the Replacement Printed Circuit Board for MaxxAir Manual Lift RV Roof Vents # MA10A21276K.

helpful expert reply by:
1
Kevin C

Products Referenced in This Question


Product Page this Question was Asked From


Q & A Icon

Similar Expert Q&A Pages

See More Q&A Expert Answers >>