bing tracking image
Q & A Icon

Troubleshooting Flashing Green light with Engage Park Brake

Question:

When I retracted the jacks my green light in the middle was flashing green and error code said the E brake wasnt engaged. Also my left fog light was flashing in sequence with the flashing green, ???

0

Expert Reply:

From what you stated it sounds like you have the touch panel that has the LCI logo in the middle that is flashing green and the red lights down the left hand side with the "engage park brake" illuminated in red.

Given the information about the fog lights flashing as well and the fact that you have engaged the parking brake but the controller is saying that you have not, it is likely that you have a wiring issue. Most likely being a faulty ground, when the controller is looking for the "E" brake it is looking for a ground when parking brake is on.

I would check that your wiring is not damaged and properly grounded. If all of that checks out you may need to look into replacing the controller and wiring harness. As long as the touch panel is the one I described above the correct replacement would be the Replacement Lippert Control Panel with Amp Connector for 4-Point Leveling System # LC175225 and the wiring harness is Replacement Lippert 4-Point Leveling System Control Brain Wiring Harness # LC178278.

If this is not the touch panel that you have please feel free to reach back out to me with what you have and I would be happy to help further troubleshoot for you.

expert reply by:
0
Scott S

Products Referenced in This Question


Product Page this Question was Asked From


Q & A Icon

Similar Expert Q&A Pages

See More Q&A Expert Answers >>