bing tracking image
Q & A Icon

Troubleshooting No Power On Curt 4-Way Wiring Harness

Question:

Had the Curt 2 plug connector hooked up and working well, now it’s getting no power to the plug…the red fuse has been changed and car fuses are good. Has the in line controller gone bad?

0

Expert Reply:

In order to narrow this down I would start by checking the vehicle side of the connector. Check and see if there is power using a circuit tester like the # PTW2993. If you find that there is power then you can rule out anything on the vehicle side and you need to be checking the # C56332
.
If you don't have power then it is a problem with the vehicle. Since you already checked your fuses it is probably a short in the wiring. If you are unable to locate it you will probably have to take it to a local shop for repair.

If the problem is on the Curt wiring harness then use the same circuit tester to see if it has power on the vehicle side of the plug. If it does not, it is probably a short in the wire which you will need to locate and repair.

If everything checks out going into the convertor box check the wires coming out. If you don't have any output then it is safe to say it is the box and you will need a new wiring harness.

I have attached a helpful article on troubleshooting 4-way wiring for your reference.

expert reply by:
0
Robin H

Products Referenced in This Question


Product Page this Question was Asked From


Q & A Icon

Similar Expert Q&A Pages

See More Q&A Expert Answers >>