bing tracking image
Q & A Icon

Troubleshooting Running Light Circuit for Curt Flat Tow Wiring on 2019 Ford Ranger

Question:

I recently purchased from you everything I need to flat tow my 2019 Ford Ranger Lariat. I started with the tail light kit and ran into a problem. The right side running lights brown wires are not working. There is voltage from the vehicle to the butt connector but nothing at the brown to Module. Same issue with truck off and power from 4-flat connector left side brown is hot, right side is dead. I do not have a schematic of the Curt C63CR so I am reaching out to you guys for help. Im guessing maybe a bad diode or maybe mislabeled to and from on the right side browns. Thanks in advance for your help.

0

Expert Reply:

That definitely doesn't sound good. The brown wires on both sides of the Curt Universal Tail Light Wiring Kit # C63CR should be sending signals since it's for different tail light sides on your 2019 Ford Ranger.

It could be a bad diode but it could also be damaged wiring. I recommend adding 12V power to the 4-Way pin with the green wire and then checking the green wire at the butt connectors to see if the signal gets to the end of the wiring. This tells you if the issue is that diode/module or if the brown wire is just damaged and needs repairing.

I've attached an installation video of this kit on a 2020 Ford F-150 that you can use to assist for the installation as well.

expert reply by:
0
Jon G

Product Page this Question was Asked From


Q & A Icon

Similar Expert Q&A Pages

See More Q&A Expert Answers >>