bing tracking image
Q & A Icon

Curt T-Connector Always Showing Power on Turn Signal of 2019 Jeep Wrangler Unlimited

Question:

I bought this harness from you 2 years ago, hooked it up and all was good. Just hooked up my utilty trailer and all I got was the running lights lit and a solid on left turn signal without even turning my lights on. No other functions are working. Hooked up the plug in 3 light tester connection plug and have the middle light left turn signal lit without tuning the lights on. Any suggestions?

0

Expert Reply:

I fear the converter of the Curt T-Connector Vehicle Wiring Harness # C56407 has gone bad on your Jeep and you'll have to replace it, but before doing that, there's a couple things to check that hopefully will work out so you don't have to. First, start with the ground wire. You will have grounded it near the converter box, and check that the ground is still good and there's no dirt/rust/corrosion impeding it, and that the wire is okay.

A poor ground may have caused a short that is causing a power draw at all times, and fixing a bad ground can remedy the issue. will also want to go and check all the other wires going into the harness to sure they aren't pinched or somehow damaged which can cause a short.

If none of those things happened, the converter box likely shorted out and you would need to replace it. If that is the case (and again, let's hope not), I would highly recommend switching away from the Curt # C56407 on your 2019 Wrangler and instead use Tekonsha, which we have found to be more reliable. The correct fit for your Jeep is the T-One Vehicle Wiring Harness # 118786.

expert reply by:
0
Kyle S

Products Referenced in This Question


Product Page this Question was Asked From


Q & A Icon

Similar Expert Q&A Pages

See More Q&A Expert Answers >>