bing tracking image
Q & A Icon

Troubleshooting Left Trailer Taillight that Doesn't Function when Running Lights are On

Question:

Followed your installation video Chevy Silverado for Pollak plug-in 40975 and wiring harness 11-998: Lights reacted as follows: 1. Tail lights on - only right side trailer lights on. 2. Tail lights off using turn signals - both turn signals flash regardless of direction, right side flashes stronger. Went back and double checked wire color match ups per video, all was as instructed see picture attached. Used Ohmeter and discovered that the order shown on the 40975 packaging GD, TM, LT, RT is actually GD, RT, LT, TM. I may have done something wrong, but I cant figure out what. The trailer lights and wiring work fine with the hitch and wiring I bought from yall for our 2010 Lexus, so I dont think the problem is there. Appreciate any help you can give me.

0

Expert Reply:

It sounds like the ground is weak on the left side of the trailer lighting. I would be willing to bet that if you were to inspect and clean how the left side light assembly grounds it would start working like normal.

When the taillights are on the maximum amount of amperage is being drawn from your vehicle and trailer so that is when a weak ground would start causing problems.

The wiring of your Lexus might have more powerful circuits and are able to overcome the weaker ground.

I attached a couple FAQ articles that you might find informative as well.

expert reply by:
0
Jameson C

Product Page this Question was Asked From


Q & A Icon

Similar Expert Q&A Pages

See More Q&A Expert Answers >>