bing tracking image
Q & A Icon

After Towing Trailer with Running Lights On Running Lights and Cruise Control Went Out

Question:

I have a prodigy brake controller hooked up with a 3025-p harness when I hooked it up all good half through my trip with running lights on the trailer running lights went out as did the cruise the brake controller was saying nc after about fifteen minutes with the lights off everything went back to normal. But if I run the running lights it does this again and again.

0

Expert Reply:

It is possible that there is a short in the harness # 3025-P. But first, make sure the red wire in the end of the harness that plugs into the truck is in the same location as the one in the picture I have included. If it is not in this location it will need to be moved there.

To determine if it is the harness that is causing the problem you can disconnect it and see if the problem goes away. If it does then there is a problem with the harness or the controller and one or both would need to be replaced. To do this test you will need to have the trailer connected with the running lights on. A large empty parking lot would be a safe place to try it out.

If the problem still occurs then it is not the brake controller. It is likely a short on the trailer side that you will need to track down. It could be anywhere from the connector, back along the wires, or at any of the lights.

It could also be a problem on the truck side wiring in the connector or along the actual tow package wiring somewhere. Its just a matter of eliminating variables until the problem is found.

click to enlarge
expert reply by:
0

Product Page this Question was Asked From


Q & A Icon

Similar Expert Q&A Pages

See More Q&A Expert Answers >>