bing tracking image
Q & A Icon

Lights Flash, Don't Work or Dim with Trailer Wiring Harness Installed on a 2009 Toyota Tacoma

Question:

Part 118496:I bought this part number a while ago for my 2009 Tacoma. Now I have a problem with my light not working properly. Im not sure what is wrong with it. But when my headlight is on, and if I press the brake, the interior light will flashing and dim. When I turn the signal left and right, all my signal light is flashing. So I unplugged the T-connector and looks like it back to normal. Can someone tell me what is wrong with this issues?

0

Expert Reply:

This sounds like a ground problem. Ground problems normally show up when there is more draw on a system such as when you have the running lights on and then use another function like a turn signal or brake light.

Make sure that the vehicle side and trailer side connectors are clean and free of corrosion inside and out. The main connector grounds should be attached to clean and corrosion free bare metal surfaces.

The light grounds should also be attached to clean and corrosion free bare metal surfaces. If there is anything between a light ground and the metal trailer frame or if the trailer has an aluminum frame, tilt bed, or folding tongue, any of these things can interrupt the ground. Running jumper wires from the light grounds to the main trailer connector ground can help.

expert reply by:
0

Product Page this Question was Asked From


Q & A Icon

Similar Expert Q&A Pages

See More Q&A Expert Answers >>