bing tracking image
Q & A Icon

Troubleshooting Trailer Taillights that Dont Blink When Running Lights are On

Question:

Hello. I just installed new 4inch AutoSmart KL-25108RK led tail lights on my stock trailer. They light up properly for stop and turn signals, but when I turn on the running lights for the head lights the tail lights come on steady no becoming brighter for brakes, and no blink for turn signals. On the pickup the lights all work properly when this is all going on. The tail lights come with 3-wire pigtails, one being the ground. I have good ground throughtout the trailer, and I already have an electronic flasher in the fuse box. Any ideas? Thanks for your time

0

Expert Reply:

What it sounds like is going on is that you have the wires from your trailer run backwards to the two illumination circuits of your trailer.

This would explain why when the running lights are on the blinkers and stop lights aren't functioning.

Since the harness of the lights has three wires you will need to make sure you are using all three of the wires. The running lights of your trailer should run to the wire on the lights that activates the lower intensity and the stop/turn circuit should run to the circuit of the light that activates the brighter intensity.

I attached an FAQ article on trailer wiring plus an FAQ on 4-way installs for you to check out to the right.

expert reply by:
0
Jameson C

Product Page this Question was Asked From


Q & A Icon

Similar Expert Q&A Pages

See More Q&A Expert Answers >>